Chapter 5. Guide

Working With Butterflyzer
Creating and Sharing Catalogs
Create a new Catalog
Save a Catalog
Close a Catalog
Open an Existing Catalog
Share a Catalog
Hiding and Showing Views
Browsing and Searching
Navigating and Collecting Web Pages
Searching the Web
Managing Searches
Navigating Searches
Updating Searches
Creating Complex Searches
Browsing Multiple Pages
Using the List Browser Mode
Using the Tiles Browser Mode
Enhanced Browsing
Semantic Browser
Reader
Taming your Web Pages and Tweets
Working with Collections
Selecting Items
Selecting a Single Item
Selecting Multiple Items
Using Logical Selections
Working with Tags
Create a New Tag
Move a Tag
Visualizing the Web
Exploring Web Pages with Graphs
Displaying Items in Graph
Displaying Multiple Items in Graph
Visualizing Complex Relationships
Displaying Related Items in Graph
Filtering Information in Graphs
Removing Items from Results
Simplifying the Graph Display
Use Scale to Make Graphs Effective
Collecting and Sharing Data
Topsy Statistics
Topsy Web Page Statistics
Topsy Author and Tweet Statistics
Google Insights
Collect Google Insights
View Google Insights
Create a Timeplot
Create a Timeline

Take a complete tour of Butterflyzer features. You can move through these topics as a tutorial, or just dive right into whatever interests you.

Working With Butterflyzer

Get Active Help. Work with Views and Catalogs. Configure Butterflyzer to do what you want.

Browsing and Searching

Browse the Web as you never have before. Use powerful search tools to find information. Quickly scan multiple web pages. Use the Semantic Browser and Reader.

Taming your Web Pages and Tweets

Organize your results using Collections and Tags.

Visualizing the Web

Use graphs to quickly find the information you need. Get rid of the clutter you don't. Discover information you didn't know existed.

Working With Butterflyzer

It's worth taking a few minutes to get familiar with how Butterflyzer does things.

Creating and Sharing Catalogs

Butterflyzer stores everything in Catalogs. Find out how to work with them.

Hiding and Showing Views

Each Catalog contains Views. Focus on the views that are important to you.

Creating and Sharing Catalogs

  • Butterflyzer stores your search and navigation results in Catalogs. Find out more about Catalogs.

  • When Butterflyzer opens for the first time, a catalog is created for you called "Main".

Create a new Catalog

To create a new catalog:

  1. Select the File Menu and create a New Catalog.

  2. If you want to give the Catalog a different name, Save it using a different name.

Save a Catalog

  • Catalogs are automatically saved when you exit Butterflyzer.

  • You can save a Catalog manually by selecting File → Save at anytime.

To name a file, or move it somewhere else, choose File Save As...

  1. Enter a name for the Catalog.

  2. Select a file-type. You have two choices:

    • bflybin This stores the Butterflyzer file as a 'binary' file. This is a lower-level data format that stores the information in a much more efficient way, but that can't be used outside of Butterflyzer. The binary format makes files much smaller, and Butterflyzer can load the files much more quickly, so you should use this format in most cases, but especially with large Catalogs.

    • bflyxml This stores the Butterflyzer file as a text document. Since it uses a common data format (XML) and is in plain text, you can open it with text editors, work with it using XML tools. The file is also easier to recover if something goes wrong.

  3. Save the file or cancel to keep the original name.

Close a Catalog

When you close a Catalog, unlike the case with a Browser Tab, the Catalog itself doesn't go away. It's saved in a file that you can reopen at anytime later. If you have a lot of Catalogs open, you may want to close some in order to conserve system resources.

  1. Select File → Close to close the current active Catalog.

  2. Select File → Close All to close all open files within Butterflyzer.

Open an Existing Catalog

Whenever you reopen Butterflyzer, all of the Catalogs you had open when you last quit are reopened for you. To re-open a Catalog that you previously closed or open a Catalog that someone has sent you, follow these steps.

Please Note: You can't open a Butterflyzer Catalog by double-clicking from a file folder or an email as you would with many other types of documents. Future versions of Butterflyzer will support this.

  1. If the Butterflyzer application isn't already running, open it.

  2. Select File → Open.

  3. Navigate to the location of your Catalog and open the file.

Share a Catalog

Butterflyzer Catalogs are just files, so unlike browser Tabs you can easily share them with others. This makes Butterflyzer files useful even when you're not using the more advanced features. And Butterflyzer Catalogs store more than the Web Pages you've visited. They also store configuration information so that other people will see an open Catalog in the same way you do.

Send a Catalog
  1. Save the Catalog somewhere that you can easily find it, for example on your desktop or in your documents folder. The file will have the extension .butter or .butterbin, depending on file format.

  2. Create a new email in your Email Application.

  3. Attach the butter file to your Email. See your email application documentation to find out how to attach files to an Email.

  4. Send the Email. (If the person receiving the Email doesn't have Butterflyzer, let them know they can get the latest version at http://butterflyzer.com!)

Receive a Catalog
  1. Save the file somewhere you can find it, such as your desktop or documents folder.

  2. Open the Catalog.

Hiding and Showing Views

When you first open Butterflyzer, there are a lot of different views open. Get rid of the clutter to focus on the task at hand.

For example, if you just want to browse the web:

  1. Click on a Catalog to make sure that it is selected. (If the Background is white, it isn't selected.)

  2. Open the View Menu and Uncheck "Show Outline" if it is checked.

  3. Uncheck "Show Graph" if it is checked.

  4. Uncheck "Show Table" if it is checked.

  5. Check "Show Browser" if it is unchecked.

You can also quickly hide and show views using the toolbar.

Find out more about the Outline, Graph View, Table View and Browser.